deterministic=True requires SQLite 3.8.3 or higher

 Lan   2021-04-06 17:15   125 人阅读  0 条评论

大概意思就是sqlite版本低了,我本地测试是没有问题的,部署到服务器之后就会这样的报错,以前都是用mysql所以不会出现这个问题

sqlite方便一些,之前也遇到过,解决了一次,办法很麻烦,需要更新本地的sqllite版本,以及更新软连接之类的,或者降低Django版本,都太麻烦了。

今天在网上找到了另一个解决办法:更换sqlite3 为 pysqlite3

新装模块pysqlite3

pip install pysqlite3

然后将报错的文件修改一下

/Team/Team_venv/lib/Python3.8/site-packages/django/db/backends/sqlite3/base.py

from pysqlite3 import dbAPI2 as Database  # 将默认数据库获取位置改为 pysqlite3

修改之后

解决

本文地址:https://www.lanol.cn/post/467.html
版权声明:本文为原创文章,版权归 Lan 所有,欢迎分享本文,转载请保留出处!

 发表评论


表情

还没有留言,还不快点抢沙发?